Signatures (Marketplace & Business Center)
Incident Report for Thryv
Resolved
This incident has been resolved, the Signatures feature is now functioning as expected. We will continue to monitor the Signatures feature for any disruptions.
Posted Nov 07, 2024 - 13:17 CST
Investigating
We are currently investigating an issue with our Signatures feature preventing users from accessing their Signatures feature.

Issue Experience: Users will encounter an error when attempting to access the Signatures feature, preventing from viewing, creating, sending Signature requests.

This incident is currently effecting:

Users: Global
Device/OS: Desktop/Browser, Mobile App
Effected Component: Signatures
Current Workaround: No Workaround
Estimated Timeline to Resolution: no ETA


We will continue to provide regular updates here regarding the incident.
Posted Nov 07, 2024 - 09:32 CST
This incident affected: Documents (Signatures).