Our development team identified the issue and implemented a fix. Issues with accessing the Thryv Business Center have been resolved and the platform is functioning normally again. We will continue to monitor for any further disruptions.
Posted Jul 08, 2026 - 12:26 CDT
Identified
Discovered: 7/8/26 11:10 AM CT Resolved: 7/8/26 12:09 PM CT
Impacted Product: Business Center Affected Feature: All Features
What does this mean for you? Users are currently getting a 503 error when attempting to access the Thryv Business Center.
Geographic Scope: Global
Current Workaround: There is no current workaround. If one becomes available we will share it here.
We are working diligently to resolve this issue; we will provide ongoing status updates.
Next Update Scheduled For: 12:40 PM CT
Posted Jul 08, 2026 - 11:42 CDT
This incident affected: Business Center (Inbox, Calendar, Clients (CRM), Sales, Documents, Marketing, Reports, Client Portal, Online Listings Management - Business Center, Online Presence, App Market - Business Center, Dashboard, Social Platform - Business Center, Mobile App - Business Center, Settings).