Command Center - Adding Additional Staff

Incident Report for Thryv

Resolved

This issue has been fully resolved and the Add Staff feature is now working as intended.
Posted Apr 07, 2025 - 16:26 CDT

Investigating

Impacted Product: Command Center
Affected Feature: Adding Additional Staff

What does this mean for you?
When attempting to Add Staff using the Add Staff button at the top right, or through My Account > Security + Staff, users are prompted with an upgrade screen regardless if seats are already available or not.

Current Workaround: No current workaround

We are working diligently to resolve this issue; we will provide ongoing status updates.
Posted Apr 07, 2025 - 12:13 CDT
This incident affected: MyAccount (Settings).