Editing Invoices in Business Center

Incident Report for Thryv

Resolved

Current Status: Operational

Started: September 9, 2025 6:51PM UTC
Resolved: September 9, 2025 8:56PM UTC

Affected Components
Service: Scheduling, Sales
Component: Invoices, Calendar sync

Update:This incident has been resolved.
Posted Sep 09, 2025 - 18:06 CDT

Monitoring

Update:
A fix was put in place, and we are currently monitoring it.
Posted Sep 09, 2025 - 16:21 CDT

Identified

Update:
The issue has been identified. Our development team is actively working on implementing a fix. We’ll provide additional updates as progress continues.
Posted Sep 09, 2025 - 15:06 CDT

Investigating

We are currently investigating an issue affecting invoice editing functionality. Some users may experience degraded performance or difficulty editing invoices. Our engineering team is actively working to identify the cause and implement a fix. We will provide the next update as soon as more information becomes available.
Posted Sep 09, 2025 - 14:21 CDT
This incident affected: Business Center (Sales - Invoicing, Estimates, Payments).