Business Center - Sending Invoice Reminders

Incident Report for Thryv

Resolved

This incident has been fully resolved and invoice reminders are working as expected.

Resolved 03/17/2025 2:44 PM.
Posted Mar 17, 2025 - 14:45 CDT

Investigating

Current Status: Partially Operational
Discovered: 3/17/2025 10:00 AM CDT

Impacted Product: Business Center
Affected Feature: Invoices

What does this mean for you?
When attempting to send payment reminders for pending, overdue, or partially paid invoices, users encounter a message that states:- I acknowledge any collected payments will be refunded."

Users should not move forward with sending the reminder at this time.


Current Workaround: No current workaround

We are working diligently to resolve this issue; we will provide ongoing status updates.
Posted Mar 17, 2025 - 13:16 CDT
This incident affected: Sales (Invoices).