Our development team has implemented a fix and accessing the Thryv Leads reporting is now working properly. We will continue to monitor for any further issues.
Posted Jan 02, 2025 - 13:12 CST
Update
Our development team continues to work on implementing a fix to resolve the issue with accessing the Thryv Leads report. Availability was limited due to the Holiday break. In the meantime please reach out to a Thryv Service Specialist for assistance with accessing Thryv Leads reporting.
Posted Jan 02, 2025 - 10:07 CST
Identified
Current Status: Partially Operational Discovered: 12/24/24 - 10:00 AM CST Resolved: 1/2/25 - 12:00 PM CST
Impacted Product: Thryv Leads Affected Feature: Thryv Leads Reporting via Business Center
What does this mean for you? At this time users cannot access the Thryv Leads report from within the Business Center. The Leads product is still working as intended, this is only effecting being able to access the report. Our development team has identified the issue and is working on implementing a fix. We will provide further updates as soon as possible.
Current Workaround: Thryv Leads reporting can still be accessed through the Command Center menu. Users without a Command Center can call our Thryv Support team at 844-998-4798 and request to be connected to a Thryv Leads specialist who can review the stats through our employee portal. Availability may be limited due to Winter Break Closing.
We are working diligently to resolve this issue; we will provide ongoing status updates.
Posted Dec 24, 2024 - 11:34 CST
This incident affected: Thryv Leads (Thryv Leads - Business Center).