Marketing Center: Latency/Access Issues - Website Editor: Access Issues

Incident Report for Thryv

Resolved

AWS has implemented fixes to successfully resolve all issues we were seeing with Thryv Marketing Center, Website Builder, and other components within the Thryv software. We will continue to monitor for any further disruptions.
Posted Oct 20, 2025 - 17:29 CDT

Update

The website editor looks to be fully functional again and can be accessed via My Account and Business Center with no issues. Most services in the Marketing Center look to be resolving as well. We continue to see some intermittent issues with data and analytics loading properly and continue to monitor for further updates from AWS for a resolution.
Posted Oct 20, 2025 - 15:21 CDT

Update

We are continuing to monitor for any further issues. Website Editor access for Professionally Designed and DIY websites are also impacted by the AWS outage.
Posted Oct 20, 2025 - 12:50 CDT

Update

We are seeing that issues with accessing Marketing Center are resolving, however the Social tab is missing from the left navigation menu completely and most of the features within Marketing Center are still not functioning properly. Our development team confirmed this is due to the impact from the AWS outage and we will continue to see things resolve over time.
Posted Oct 20, 2025 - 11:56 CDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 10:24 CDT

Monitoring

Current Status: Intermittent Downtime
Discovered: 10/20/2025 2:11 AM CST
Resolved:

Impacted Product: Marketing Center
Affected Feature: Overview, Listings, Analytics, Social

What does this mean for you?
Users are reporting issues with being able to access their Thryv Marketing Center. Users who can access Marketing Center report latency issues, or being unable to save changes.

These issues are stemming from an outage impacting Amazon Web Services that occurred overnight/early this morning 10/20/2025 AWS has reported implementing fixes that have mitigated issues, but we are still seeing lingering issues from the outage. We are working with our internal devs to ensure no action is needed on our end. We will share further updates as they become available.

Current Workaround: no current workaround

We are working diligently to resolve this issue; we will provide ongoing status updates.
Posted Oct 20, 2025 - 09:44 CDT
This incident affected: Marketing Center (Marketing Center Overview, Analytics, Marketing Center Social, Tools, Trackable Phone Number, Marketing Center Listings Management, Reputation - Review Response, Marketing Center SEO), Online Presence (Website), and Business Center (Website).