Marketing Center - Overview Page

Incident Report for Thryv

Resolved

This incident has been fully resolved. Please reach out to our support team here at #844-998-4798 if you are still experiencing issues.
Posted Apr 18, 2025 - 13:33 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 18, 2025 - 12:22 CDT

Investigating

Current Status: Marketing Center Partially Operational
Discovered: 4/18/2025 10:00 AM CST
Resolved:

Impacted Product: Marketing Center
Affected Feature: Marketing Center Overview Metrics

What does this mean for you?
Marketing Center is experiencing an issue where no metrics are showing on the overview page. Users are met with an error on each section of the page. We are investigating the root cause with urgency.

Current Workaround: Metrics can be seen on those individual pages (reputation, analytics, tools). The overview page is the only page experiencing issues.

We are working diligently to resolve this issue; we will provide ongoing status updates.
Posted Apr 18, 2025 - 10:28 CDT
This incident affected: Marketing Center (Marketing Center Overview).