Business Center - Invoices & Estimates

Incident Report for Thryv

Resolved

This incident has been resolved.
Posted Feb 05, 2025 - 11:26 CST

Monitoring

A fix has been implemented and we are monitoring closely to ensure the issue is no longer occurring.
Posted Feb 05, 2025 - 09:32 CST

Investigating

Current Status: Degraded Performance
Discovered: 2/4/2025 - 9:45 AM CST
Resolved: 2/4/2025 - 3:30 PM CST

Impacted Product: Business Center
Affected Feature: Invoices & Estimates

What does this mean for you?
When creating an Invoice or Estimate we are seeing that the pre selected Bill To contact fields are not displaying under the Bill To section as they should. Only the contact name is displaying under the Bill To section. Invoices and Estimates are functioning normally otherwise, and the issue seems to be intermittent.

Current Workaround: No current workaround

We are working diligently to resolve this issue; we will provide ongoing status updates.
Posted Feb 04, 2025 - 13:39 CST