Business Center - Mobile App and Desktop

Incident Report for Thryv

Resolved

Our development team has implemented a fix that has resolved the issue. We suggest users to log out, force close the app in the background, and log in one more time. Please reach out to our Thryv support team if any further issues persist.
Posted Nov 27, 2025 - 09:30 CST

Update

The fix our development team released did not fully resolve the issue experienced when logging in to the Business Center mobile app. Some users are still seeing an error when first logging in to their Business Center mobile app which requires the app to be force stopped in the background and reopened. Our development team continues to work towards fully resolving this issue. We will continue to provide updates until fully resolved.
Posted Nov 27, 2025 - 07:54 CST

Update

Our development team is actively working to resolve the issue encountered when logging in to the Business Center mobile app, with an expected fix to be released early tomorrow morning, 11/27/2025.

Current Workaround: Force stop the app running in the background and reopen it. This step may need to be repeated more than once.
Posted Nov 26, 2025 - 16:42 CST

Identified

We have confirmed that issues with the Business Center desktop app and calendar are no longer occurring.

We are still experiencing issues with logging in to the Business Center mobile app. Users are still being met with a blank screen in some cases.

As a reminder, force stopping the app in the background and reopening the app will resolve the mobile app issue as a workaround. This step may need to be done more than once.

Our development team continues to work towards a resolution and we will send further updates as they become available.
Posted Nov 26, 2025 - 13:57 CST

Monitoring

A fix has been implemented for this issue and we are monitoring for any further disruptions. If any further issues persist accessing the Business Center mobile app or desktop version please contact our Thryv support team.
Posted Nov 26, 2025 - 10:45 CST

Investigating

Current Status: Intermittent downtime
Discovered: 11/28/25 5am CST
Resolved:

Impacted Product: Business Center
Affected Feature: Mobile App, Calendar on Desktop app

What does this mean for you?
Users are reporting issues with accessing the Business Center on the mobile app and desktop version. On the desktop, some users are seeing a blank screen when navigating to the calendar tab. In some cases the screen remains blank when attempting to navigate to a different feature in the app.

On mobile app some users are seeing a blank screen after attempting to log in.

Current Workaround: For the desktop; clearing your browsers cache and cookies for all time and restarting the browser will resolve desktop issues at least temporarily.

For the mobile app; force stopping the app in the background and reopening the app will resolve the app issue. This step may need to be done more than once.

We are working diligently to resolve this issue; we will provide ongoing status updates.
Posted Nov 26, 2025 - 09:04 CST
This incident affected: Mobile App (Business Center Mobile App) and Business Center (Calendar).