Business Center - Calendar on Mobile Application and Desktop

Incident Report for Thryv

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 11:30 CST

Monitoring

A fix has been implemented and we are monitoring the results. If any further issues persist on the Business Center mobile application or desktop application please contact our Thryv support team.
Posted Dec 02, 2025 - 10:31 CST

Investigating

Current Status: Partially Operational
Discovered: 12/2/2025 9AM CST
Resolved:

Impacted Product: Business Center - Mobile and Desktop
Affected Feature: Calendar/Scheduling

What does this mean for you?
Users are experiencing issues accessing the Calendar in the Business Center software. When accessing the Calendar will spin and never fully load. For users who have the Calendar as their default page, they may see a blank screen when attempting to log in.

Current Workaround: Using an "incognito" or "private" browser tab will allow users to access the software with no issue. Users on the mobile app can try a mobile browser to access.

We are working diligently to resolve this issue; we will provide ongoing status updates.
Posted Dec 02, 2025 - 10:27 CST
This incident affected: Mobile App (Business Center Mobile App) and Business Center (Calendar).