Business Center Mobile App - Access Error

Incident Report for Thryv

Resolved

The issue preventing users from accessing the Business Center mobile app has been fully resolved.
Posted Nov 25, 2025 - 10:37 CST

Monitoring

A fix has been implemented and we are monitoring for any further issues.
Posted Nov 25, 2025 - 09:24 CST

Identified

Current Status: Partial Outage
Discovered: 11/25/2025 7:30 AM CST
Resolved:

Impacted Product: Business Center Mobile App
Affected Feature: All Features

What does this mean for you?
Users are unable to access the BC mobile app at this time. Users are met with a blank screen and the app will not load.

Current Workaround: Accessing Business Center on a mobile browser works as intended

We are working diligently to resolve this issue; we will provide ongoing status updates.
Posted Nov 25, 2025 - 09:19 CST
This incident affected: Mobile App (Business Center Mobile App).